搜索
您的当前位置:首页正文

最大长方形(二)

来源:吉趣旅游网

最大长方形(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
输入
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
输出
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
样例输入
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
样例输出
8
4000
来源



题意  :找最大长方形,显然暴力肯定超时,这个时候应该用记忆化的方法。h 数组存高度  ,l数组存连续比当前高度高的最左边的位置   r数组存连续比当前高度高的最右边的位置 


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<math.h>
#include<queue>;
#include<stack>;
#include <iomanip>;
#define INF 0x3f3f3f3f
using namespace std;
long long h[110000];
int l[110000];
int r[110000];
int main()
{
   int n;
   int e,i;
   while(~scanf("%d",&n)&&n)
   {
       for( i=1;i<=n;i++)
       {
           scanf("%lld",&h[i]);
       }
       for(i=1;i<=n;i++)
       {
          l[i]=i;   //初始化
          r[i]=i;
       }
       for( i=1;i<=n;i++)
       {
           e=i-1;   
           while(h[i]<=h[e])
           {
             l[i]=l[l[e]];         
             e=l[i]-1;
           }
       }
         for( i=n;i>=1;i--)    //如果还是1到n会超时 
       {
            e=i+1;
           while(h[i]<=h[e])
           {
             r[i]=r[r[e]];
             e=r[i]+1;
           }
       }
       long long ans=0;
       for( i=1;i<=n;i++)
       {
           if(h[i]*(r[i]-l[i]+1)>ans)
            ans=h[i]*(r[i]-l[i]+1);
       }
       printf("%lld\n",ans);
   }
}



因篇幅问题不能全部显示,请点此查看更多更全内容

Top